Experience: is what you get soon after you need it.

Experience: is what you get soon after you need it.

****************I am authoring a Book on Oracle Database Cloud Services.......More details to follow.***************

Title : Oracle Database Cloud Revealed
Publisher : Apress
Release Date : Jan-2019

**********************************************************************************


Rasul Allah (sal Allahu alaihi wa sallam) said: "Restore the trusts of those who trust you, and deal not falsely with him who deals falsely with you." [Abu Dawud, Tirmidhi]


My Cloud Certifications:
Oracle Cloud Infrastructure 2018 Certified Architect Associate.
Oracle Cloud Infrastructure Classic 2018 Certified Architect Associate.
Oracle Database Cloud Administrator Certified Professional.
Oracle Database Cloud Service Operations Certified Associate.

Search This Blog

Tuesday, December 5, 2017

Oracle database cloud 12c - Precheck failed for patch [26609783-EE]. Error [please upgrade to recommended dbaastools version



When trying to apply a patch via dbaas tools/console you may get the below error:
Precheck failed for patch [26609783-EE]. Error [please upgrade to recommended dbaastools version






Fix:-

Upgrade the dbaas tools version to the latest available version.

Check your current version of cloud tooling:

Login as root:

[opc@ERP1 ~]$ sudo su -
[root@ERP1 ~]#

check the rpm version:

[root@ERP1 ~]# rpm -qa|grep -i dbaastools
dbaastools-1.0-1+17.3.5.0.0_170731.1639.x86_64
[root@ERP1 ~]# dbaascli dbpatchm --run -list_tools -cli
DBAAS CLI version 1.0.0
Executing command dbpatchm --run -list_tools -cli -cli
/var/opt/oracle/patch/dbpatchm -list_tools -cli -cli
Starting DBPATCHM
Logfile is /var/opt/oracle/log/dbpatchm/dbpatchm_2017-12-05_19:45:13.log
Config file is /var/opt/oracle/patch/dbpatchm.cfg

INFO: cdb is set to : yes
INFO: dbversion detected : 12102
INFO: patching type : psu

Patchid : 17.3.5.1.0_170908.0000
Patchid : 17.3.5.1.0_170922.0000
Patchid : 17.3.5.1.0_171006.0000
Patchid : 17.3.5.1.0_171020.0000
Patchid : 17.3.5.1.0_171027.0000
Patchid : 17.3.5.1.0_171103.0000
Patchid : 17.4.3.1.0_171115.0000
Patchid : 17.4.3.1.0_171129.0000

dbpatchm Execution completed

Latest patch id available is - Patchid : 17.4.3.1.0_171129.0000

Let's upgrade the rpm to the latest version.

[root@ERP1 ~]# dbaascli dbpatchm --run -toolsinst -rpmversion=17.4.3.1.0_171129.0000
DBAAS CLI version 1.0.0
Executing command dbpatchm --run -toolsinst -rpmversion=17.4.3.1.0_171129.0000 -cli
/var/opt/oracle/patch/dbpatchm -toolsinst -rpmversion=17.4.3.1.0_171129.0000 -cli
Starting DBPATCHM
Logfile is /var/opt/oracle/log/dbpatchm/dbpatchm_2017-12-05_19:46:00.log

WARN : Parameter toolsinst passed via cmdline is not a valid parameter. Please check the usage.
Config file is /var/opt/oracle/patch/dbpatchm.cfg

INFO: cdb is set to : yes
INFO: dbversion detected : 12102
INFO: patching type : psu

INFO: existing dbaastools version - dbaastools-1.0-1+17.3.5.0.0_170731.1639.x86_64

INFO: updated dbaastools rpm to - dbaastools-1.0-1+17.4.3.1.0_171129.0734.x86_64
dbpatchm Execution completed

Now verify the tools version after the rpm upgrade.
[root@ERP1 ~]# rpm -qa|grep -i dbaastools
dbaastools-1.0-1+17.4.3.1.0_171129.0734.x86_64

2 comments:

arvind kumar said...

Its worked for me.

Many thanks Sameer.


Regards,
Arvind

Cedric said...

It has worked for me as well.

Thanks!
Cedric