Experience: is what you get soon after you need it.
GIAC Cloud Penetration Tester (GCPN)
GIAC Cloud Security Automation (GCSA)
GIAC Security Essentials (GSEC)
Certified Kubernetes Administrator (CKA)
Cloud Certified Security Professional (ISC2)
CyberSecurity Certified Professional (ISC2)
AWS Certified Solutions Architect Associate
Azure Certified Architect Expert
Azure Certified Architect
Azure Certified Administrator
Oracle Cloud Infrastructure 2018 Certified Architect Associate.
Oracle Cloud Infrastructure Classic 2018 Certified Architect Associate.
Oracle Database Cloud Administrator Certified Professional.
Oracle Database Cloud Service Operations Certified Associate.
Search This Blog
Saturday, July 23, 2011
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
when I saw the allert log.
"alert_BIDB.log" 73844 lines, 3767957 characters
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
ORA-1653: unable to extend table SYS.AUD$ by 128 in tablespace SYSTEM
and even I cannot login into the DB via TOAD.
so logged into the unix server directly and invoked the sqlplus.
and then backed up the aud$ table and truncated the data in it.
SQL> select count(*) from aud$;
COUNT(*)
----------
143413
SQL> Create table Aud$_bkp tablespace users as select * from aud$ ;
Table created.
SQL> truncate table aud$;
Table truncated.
SQL> select count(*) from aud$;
COUNT(*)
----------
0
SQL> SELECT USER_NAME, AUDIT_OPTION, SUCCESS, FAILURE
FROM sys.dba_stmt_audit_opts
where SUCCESS='BY SESSION' or FAILURE='BY SESSION'
union
SELECT USER_NAME, PRIVILEGE, SUCCESS, FAILURE
FROM sys.dba_priv_audit_opts;
from the above output ran the noaudit to diable auditing.
SQL> noaudit ALTER PROFILE,CREATE ANY JOB ,CREATE ANY LIBRARY ,CREATE EXTERNAL JOB ,CREATE USER,DROP ANY TABLE,DROP USER , EXEMPT ACCESS POLICY ;
Noaudit succeeded.
SQL>
SQL> commit;
Commit complete.
2 comments:
Great article...you saved the next mornung for me. Just wanted to update our ERP when I ran across that error. Thought I had to wait for our ERP support next morning while 50 people wouldn't be able to work. Could fix it with the help of you articel myself and will phone the support tomorrow about this issue.
Thanks again,
Carsten
Thanks a lot..........It solved my problem.
Post a Comment